Potential issues adding Expensya cards to users

Incident Report for Expensya

Resolved

Dear users,

The incident has been resolved.
Thank you for your patience.

Best regards
Posted Oct 16, 2025 - 16:39 CEST

Identified

Dear users,
Admins may experience issues when adding Expensya cards to users.
Our team has identified the cause and is actively working on a fix.

We appreciate your patience and understanding.
Posted Oct 16, 2025 - 13:21 CEST
This incident affected: Expensya Card.