We are pleased to inform you that the earlier reported slowness on our web and mobile apps has significantly improved and we are currently monitoring the situation to ensure stability.
We apologize for any inconvenience this may have caused and we appreciate your patience and understanding during this time.
Sincerely,
Posted Nov 14, 2024 - 12:40 CET
Update
We are currently experiencing an unexpected issue with our Cloud provider Microsoft Azure, we are actively working on resolving it.
Posted Nov 14, 2024 - 11:03 CET
Identified
The issue has been identified, and a fix is being implemented
Posted Nov 14, 2024 - 10:00 CET
Investigating
Dear Users, We are currently experiencing some slowness on both our Web and mobile Apps. Our team is actively working on the issue, and we expect it to be temporary. During this time, you may encounter some delays. If possible, we recommend postponing non-urgent tasks on Expensya. We will keep you updated soon. We appreciate your patience. Sincerely,
Posted Nov 14, 2024 - 09:28 CET
This incident affected: Web Application and Mobile Application.