Performance degradation

Incident Report for Expensya

Resolved

Dear users,

This incident has been resolved.
Thank you again for your patience.

Sincerely,
Posted Mar 10, 2025 - 12:47 CET

Identified

This is issue has been identified and a fix is being deployed.
We will keep you updated.
Posted Mar 10, 2025 - 11:25 CET

Investigating

Dear Users,

We are currently experiencing some slowness on both our Web and mobile Apps.
Our team is actively working on the issue, and we expect it to be temporary.

During this time, you may encounter some delays. If possible, we recommend postponing non-urgent tasks related to the Expense module.

We will keep you informed and are working quickly to resolve this issue.

Thank you for your patience

Sincerely,
Posted Mar 10, 2025 - 09:19 CET
This incident affected: Web Application and Mobile Application.