Performance degradation
Incident Report for Expensya
Resolved
This incident has been resolved.
Thank you for your patience.
Posted Mar 29, 2024 - 18:14 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 29, 2024 - 17:50 CET
Monitoring
A fix has been implemented and response times are back to normal.
We are monitoring the results.
Posted Mar 29, 2024 - 17:24 CET
Identified
The issue has been identified and a fix is being implemented.
Next update in 15 mins
Posted Mar 29, 2024 - 17:13 CET
Investigating
Dear users,
We apologize for any inconvenience, but due to unexpected circumstances, our system is currently running slower than usual.
We have proactively informed you and are making sure that all activities returns to normal.
Next update in 15 mins
Posted Mar 29, 2024 - 16:59 CET
This incident affected: Web Application and Mobile Application.