Mobile App Access Issue

Incident Report for Expensya

Resolved

Version 8.1.0 is now available on the Play Store. Users currently on version 8.0.9 are advised to update to 8.1.0.

Thank you for your understanding.
Posted Jun 05, 2025 - 14:09 CEST

Update

We are continuing to investigate this issue.
Posted Jun 05, 2025 - 13:11 CEST

Investigating

Dear Users,

We are currently experiencing an access issue with the mobile app. Our team is actively working on resolving it.
This issue is impacting only version 8.0.9 of the Android app.
We will keep you informed and are working quickly to resolve this issue.

Thank you for your patience

Sincerely,
Posted Jun 05, 2025 - 12:50 CEST
This incident affected: Mobile Application.