Performance degradation
Incident Report for Expensya
Resolved
Dear users,

The response time has almost returned to normal as the usage is decreased.

We apologize for any inconvenience caused by this slowness and we thank you for your patience.

Sincerely.
Posted Dec 20, 2024 - 18:43 CET
Identified
Dear Users,

This slowness is due to high usage in this end of year period.
Our technical team is employing all of its resources and efforts to improve the response time and stabilizing it as much as possible.

If you are experiencing slowness, we kindly ask you to postpone non-urgent tasks to a later time.

We apologize for any inconvenience caused and thank you for your understanding.

Sincerely.
Posted Dec 20, 2024 - 14:30 CET
Update
Dear User,

We are actively investigating the slowness issues on our Web and mobile Apps.
Progress is being made, but delays may still happen.
Please postpone non-essential tasks if possible.

Thank you for your patience.
More updates soon.

Sincerely,
Posted Dec 20, 2024 - 10:40 CET
Investigating
Dear User,

We're currently experiencing some slowness on our Web and mobile Apps.
Our team is on the task and we expect this issue to be temporary.
During this time, you might face some delays; if possible, we suggest postponing non-urgent tasks on Expensya.

We will keep you updated and will work promptly to resolve this issue soon. We appreciate your patience.

Sincerely,
Posted Dec 20, 2024 - 09:54 CET
This incident affected: Web Application and Mobile Application.