Performance degradation
Incident Report for Expensya
Resolved
This incident has been resolved and response time is back to normal

Best Regards
Posted Aug 19, 2024 - 16:48 CEST
Update
We are continuing to monitor for any further issue.

Thank you for your understanding.
Posted Aug 19, 2024 - 16:15 CEST
Monitoring
Dear User,

We're currently experiencing some intermittent slowness on our Web and mobile Apps.
Our team is on the task monitoring and we expect this issue to be temporary.
During this time, you might face some delays; if possible, we suggest postponing non-urgent tasks on Expensya.

We will keep you updated soon. We appreciate your patience.

Sincerely,
Posted Aug 19, 2024 - 15:05 CEST
This incident affected: Web Application and Mobile Application.