We want to reassure you that after implementing a temporary fix, the performance of our web and mobile apps has notably improved.
Currently, our team is dedicated to developing a definitive fix that will offer sustained high-quality performance. In the meantime, we are monitoring the situation closely to ensure improved stability. We appreciate your patience and understanding as we continue to make these improvements.
Thanks for your support,
Sincerely,
Posted Sep 30, 2024 - 15:10 CEST
Monitoring
Dear Users,
We are pleased to inform you that the earlier reported slowness on our web and mobile apps has significantly improved and we are currently monitoring the situation to ensure stability.
We apologize for any inconvenience this may have caused and we appreciate your patience and understanding during this time.
Sincerely,
Posted Sep 30, 2024 - 12:41 CEST
Identified
Dear Customers,
We've noticed that old versions of the Expensya Next Mobile app are generating an unusually high number of requests when the user session expires. This behavior might have degraded the overall performance and user experience.
You can mitigate this issue with the following workaround:
1. Log out from the application. 2. To ensure you have the latest mobile update, uninstall and then reinstall the application. 3. Log back in to complete the process.
We are actively working on resolving this issue permanently and improving the app's performance. We apologize for any inconvenience this may cause and thank you for your patience as we work to resolve it.
We will provide more updates as the situation unfolds. Thank you for your understanding and continued support.
Posted Sep 30, 2024 - 12:21 CEST
Investigating
Dear Users,
We're currently experiencing some slowness on our Web and mobile Apps.
Our team is on the task and we expect this issue to be temporary.
During this time, you might face some delays; if possible, we suggest postponing non-urgent tasks on Expensya.
We will keep you updated and will work promptly to resolve this issue soon.
We appreciate your patience.
Posted Sep 30, 2024 - 11:28 CEST
This incident affected: Web Application and Mobile Application.