Performance degradation
Incident Report for Expensya
Resolved
Dear users,

This incident has been resolved.
Thank you for your patience.
Posted Mar 28, 2024 - 14:06 CET
Monitoring
Dear users,

Service is functionnal again.
Our technical team continues monitoring to ensure that all activities continue smoothly.
Posted Mar 28, 2024 - 13:52 CET
Investigating
Dear users,
We are currently experiencing slower than usual production due to a spike in usage.
We have proactively informed you and are making sure that all activities returns to normal.
Next update in 15 mins
Posted Mar 28, 2024 - 13:45 CET
This incident affected: Web Application and Mobile Application.