Performance degradation
Incident Report for Expensya
Resolved
Dear User,

We are pleased to inform you that the earlier reported slowness on our Web and mobile apps has been resolved.
Our services are now back to normal.
We apologize for any inconvenience that this may have caused and we appreciate your patience and understanding during this time.

Sincerely,
Posted Jul 23, 2024 - 11:04 CEST
Monitoring
Dear Users,

We are pleased to inform you that the earlier reported slowness on our Web and mobile apps has significantly improved and we are currently monitoring the situation to ensure stability.
We apologize for any inconvenience this may have caused and we appreciate your patience and understanding during this time.

Sincerely,
Posted Jul 23, 2024 - 10:40 CEST
Identified
We're still addressing the slowness on our Web and mobile apps.

Our technical team is actively working to resolve the problem.

During this time, you may still encounter minor delays. We appreciate your continued patience and will keep you updated as we make progress.

Sincerely,
Posted Jul 23, 2024 - 09:57 CEST
Investigating
Dear User,

We're currently experiencing some slowness on our Web and mobile Apps.
Our team is on the task and we expect this issue to be temporary.
During this time, you might face some delays; if possible, we suggest postponing non-urgent tasks on Expensya.

We will keep you updated soon. We appreciate your patience.

Sincerely,
Posted Jul 23, 2024 - 09:42 CEST
This incident affected: Web Application and Mobile Application.